{"name":"TexView 2 Manual","title":"TexView 2 Manual","type":"topic","url":"https://community.bistudio.com/wiki/TexView_2_Manual","revid":364102,"updated":"2024-05-04T21:54:10Z","aliases":[],"markdown":"TexView 2 is a texture viewer and conversion tool supporting Real Virtuality Engine's internal texture formats.\nTexView 2 is provided free of charge for any non-commercial use without any support from Bohemia Interactive. Use it at your own risk.\nRefer to the end user license agreement as displayed during the setup process of this application for more details.\n\n#### Supported Formats\n\n| Input | Output |\n|---|---|\n| - JPG<br>- TGA (24 bit / 32 bit with alpha channel)<br>- PNG (with or without alpha channel)<br>- PAA<br>- PAC<br>> [!IMPORTANT]<br>> All input textures **must** have a power of two-based resolution like 2^x / 2^y (e.g. 16 / 16, 32 / 32, 64 / 64, 256 /256).<br>><br>> The largest texture size commonly supported by graphics cards and BI's game engines is 2048x2048,<br>><br>> in Arma 3 4096x4096 textures are supported (and are in TexView 2). | - PAA/PAC (file format is used depending on file name as defined in textureconvert.cfg file)<br>- TGA (32 bit with alpha channel)<br>- PNG (with alpha channel) |\n\n#### How to use it\n\nYou can open any supported image using menu File / Open or drag and drop the image file icon into the main window of Texview (tip: you may assign PAA file extensions to TexView 2application using Windows desktop).\n\nYou can save the file into the format you need. The output file format (PAC, PAA or TGA) will be choosen depending on the extension you write in \"Save As...\" dialog to the filename line.\nBit depth and optional alpha channel will be selected automatically depending on the file name as defined in textureconvert.cfg file, default is:\n\n- _CO - color (diffuse map)\n- _CA - color alpha (diffuse map with alpha)\n- _NO - normal map\n- _NS - normal map specular (with alpha)\n- _NON - normal map with noise in alpha channel ( noise is used for vegetation lods blending)\n- _NOF - normal map faded (mipmaps fade the texture in distance, usefull for terrain)\n- _NOHQ - normal map high quality\n- _NOVHQ - normal map high quality\n- _DT - detail texture, average color should be 0.5, texture has got fad out filter in mipmaps\n- _CDT - colored detail texture, average color should be 0.5 in all R G B channels, texture has got fad out filter in mipmaps\n- _SKY - sky texture\n- _MC - macro texture\n- _AS - ambient shadow texture\n- _SM - specular map HQ normálové mapy (HQ Normal Maps)\n- _SMDI - optimised specular mapa for better bitdepth HQ_normálové_mapy_\n- _LCO - land color map, texture used for satelite and mask textures on the terrain\n- _MCO - multiply color map, texture used to multiply with color map (as cdt) without fade out filter, average color should be 0.5 in all R G B channels\n\nThe texture name should be simple ascii, containing only letters, digits and underscore (no letters with diacritics). Only one dot is allowed leading the extension.\n\nExample of texture name: M151A1_fuelTank01_CO.tga\n\nThe source texture file format is PNG (preferred) or TGA (no compression, only 24b or 32b).\n\nPlease be aware that bit depth of the exported texture may be lower than bit depth of your source image and compression causing some visual artifacts can be applied.\nDuring the export all mipmap levels of the texture will be created automatically. Alternatively, you can also move the texture by holding the middle mouse button.\n\nReference: Arma: Texture Naming Rules.\n\n#### Available Functions\n\n##### File\n\n###### Open\n\n<kbd>Ctrl</kbd> + <kbd>O</kbd>\n\nopen an image file\n\n###### Save\n\n<kbd>Ctrl</kbd> + <kbd>S</kbd>\n\nSaves the file in the support file format (paa is default for any unsupported extension)\n\n###### Refresh\n\n<kbd>F5</kbd>\n\nReloads the file\n\n###### Save as...\n\nExport the image file to desired format (default is paa but you can manually change the extension to tga or png)\n\n###### Source control\n\nAllows to bind data to a scc compliant source control system\n\n###### Generate\n\nAllows simple procedural texture generation based on formulas, example of a circle texture:\n\n```\na = abs u < sqrt(1 - v * v);\nr = a;\ng = a;\nb = a;\n```\n\n###### Previous File / Next File\n\n<kbd>↟ PgUp</kbd> (previous file) / <kbd>↡ PgDown</kbd> (next file)\n\nBrowses the current directory for other bitmaps\n\n##### Edit > Filter\n\nFilter process executed for each pixel of the texture. You can load some of pre-made useful filters stored in Filters subfolder of main Tex View 2 working directory.\n\n##### MipMap\n\n###### Prev\n\n<kbd>↑</kbd>\n\nDisplay the previous mipmap level\n\n###### Next\n\n<kbd>↓</kbd>\n\nDisplay the next mipmap level\n\n###### Preview mipmaps\n\nGenerate mipmaps\n\n###### Preview mipmap\n\nSpecific types: preview various specific supported mipmap types\n\n##### View\n\n###### Status Bar\n\nDisplay resolution of the currently displayed mipmap and maximum resolution of the texture and status of Tex View 2\n\n###### Info bar\n\nDisplay max, avg and under cursor color in RGBA\n\n###### View bar\n\nAllows you to select, preview and compare various types of textures (note that texture type to be stored is determined by filename only and this is only for preview purposes)\n\n###### Zoom In / Zoom Out\n\n<kbd>NUM +</kbd> / <kbd>NUM -</kbd>\n\nZoom the texture in and out (you can also use mouse wheel to zoom in and out)\n\n###### RGB\n\nShow RGB values on a 0..1 scale (not 0..255)\n\n##### Mouse controls\n\nHold {{Right Mouse Button and drag the texture by mouse if it cannot fit on screen, use mouse wheel to zoom in and out.\n\n#### Command Line Conversion\n\nFor command line and batch conversions use Pal2PacE.exe.\n\n**Arguments Usage**:\n\n```\npal2pace [saveoptions] <source> [<destination>]\npal2pac -combine [saveoptions] [options] <source1> <source2> <source3> <source4> <destination>\n```\n\n**SaveOptions**:\n\n```\n        -size=<n>\n\nOptions (obsolete, no longer useful for {{arma1}}):\n        -xborder=<bordersize> (0<bordersize<0.5, default 0.125)\n        -yborder=<bordersize>\n        -mask=<maskname>\n        -water=<watername>\n\nExample of how to generate new [[paa]] files from TGA sources:\n Pal2PacE x:\\Test\\*.tga\n```\n\n### See Also\n\n- TexView 2\n- PAA File Format\n- Arma: Texture Naming Rules","sections":[{"heading":null,"level":1,"markdown":"TexView 2 is a texture viewer and conversion tool supporting Real Virtuality Engine's internal texture formats.\nTexView 2 is provided free of charge for any non-commercial use without any support from Bohemia Interactive. Use it at your own risk.\nRefer to the end user license agreement as displayed during the setup process of this application for more details."},{"heading":"Supported Formats","level":4,"markdown":"| Input | Output |\n|---|---|\n| - JPG<br>- TGA (24 bit / 32 bit with alpha channel)<br>- PNG (with or without alpha channel)<br>- PAA<br>- PAC<br>> [!IMPORTANT]<br>> All input textures **must** have a power of two-based resolution like 2^x / 2^y (e.g. 16 / 16, 32 / 32, 64 / 64, 256 /256).<br>><br>> The largest texture size commonly supported by graphics cards and BI's game engines is 2048x2048,<br>><br>> in Arma 3 4096x4096 textures are supported (and are in TexView 2). | - PAA/PAC (file format is used depending on file name as defined in textureconvert.cfg file)<br>- TGA (32 bit with alpha channel)<br>- PNG (with alpha channel) |"},{"heading":"How to use it","level":4,"markdown":"You can open any supported image using menu File / Open or drag and drop the image file icon into the main window of Texview (tip: you may assign PAA file extensions to TexView 2application using Windows desktop).\n\nYou can save the file into the format you need. The output file format (PAC, PAA or TGA) will be choosen depending on the extension you write in \"Save As...\" dialog to the filename line.\nBit depth and optional alpha channel will be selected automatically depending on the file name as defined in textureconvert.cfg file, default is:\n\n- _CO - color (diffuse map)\n- _CA - color alpha (diffuse map with alpha)\n- _NO - normal map\n- _NS - normal map specular (with alpha)\n- _NON - normal map with noise in alpha channel ( noise is used for vegetation lods blending)\n- _NOF - normal map faded (mipmaps fade the texture in distance, usefull for terrain)\n- _NOHQ - normal map high quality\n- _NOVHQ - normal map high quality\n- _DT - detail texture, average color should be 0.5, texture has got fad out filter in mipmaps\n- _CDT - colored detail texture, average color should be 0.5 in all R G B channels, texture has got fad out filter in mipmaps\n- _SKY - sky texture\n- _MC - macro texture\n- _AS - ambient shadow texture\n- _SM - specular map HQ normálové mapy (HQ Normal Maps)\n- _SMDI - optimised specular mapa for better bitdepth HQ_normálové_mapy_\n- _LCO - land color map, texture used for satelite and mask textures on the terrain\n- _MCO - multiply color map, texture used to multiply with color map (as cdt) without fade out filter, average color should be 0.5 in all R G B channels\n\nThe texture name should be simple ascii, containing only letters, digits and underscore (no letters with diacritics). Only one dot is allowed leading the extension.\n\nExample of texture name: M151A1_fuelTank01_CO.tga\n\nThe source texture file format is PNG (preferred) or TGA (no compression, only 24b or 32b).\n\nPlease be aware that bit depth of the exported texture may be lower than bit depth of your source image and compression causing some visual artifacts can be applied.\nDuring the export all mipmap levels of the texture will be created automatically. Alternatively, you can also move the texture by holding the middle mouse button.\n\nReference: Arma: Texture Naming Rules."},{"heading":"Available Functions","level":4,"markdown":""},{"heading":"File","level":5,"markdown":""},{"heading":"Open","level":6,"markdown":"<kbd>Ctrl</kbd> + <kbd>O</kbd>\n\nopen an image file"},{"heading":"Save","level":6,"markdown":"<kbd>Ctrl</kbd> + <kbd>S</kbd>\n\nSaves the file in the support file format (paa is default for any unsupported extension)"},{"heading":"Refresh","level":6,"markdown":"<kbd>F5</kbd>\n\nReloads the file"},{"heading":"Save as...","level":6,"markdown":"Export the image file to desired format (default is paa but you can manually change the extension to tga or png)"},{"heading":"Source control","level":6,"markdown":"Allows to bind data to a scc compliant source control system"},{"heading":"Generate","level":6,"markdown":"Allows simple procedural texture generation based on formulas, example of a circle texture:\n\n```\na = abs u < sqrt(1 - v * v);\nr = a;\ng = a;\nb = a;\n```"},{"heading":"Previous File / Next File","level":6,"markdown":"<kbd>↟ PgUp</kbd> (previous file) / <kbd>↡ PgDown</kbd> (next file)\n\nBrowses the current directory for other bitmaps"},{"heading":"Edit > Filter","level":5,"markdown":"Filter process executed for each pixel of the texture. You can load some of pre-made useful filters stored in Filters subfolder of main Tex View 2 working directory."},{"heading":"MipMap","level":5,"markdown":""},{"heading":"Prev","level":6,"markdown":"<kbd>↑</kbd>\n\nDisplay the previous mipmap level"},{"heading":"Next","level":6,"markdown":"<kbd>↓</kbd>\n\nDisplay the next mipmap level"},{"heading":"Preview mipmaps","level":6,"markdown":"Generate mipmaps"},{"heading":"Preview mipmap","level":6,"markdown":"Specific types: preview various specific supported mipmap types"},{"heading":"View","level":5,"markdown":""},{"heading":"Status Bar","level":6,"markdown":"Display resolution of the currently displayed mipmap and maximum resolution of the texture and status of Tex View 2"},{"heading":"Info bar","level":6,"markdown":"Display max, avg and under cursor color in RGBA"},{"heading":"View bar","level":6,"markdown":"Allows you to select, preview and compare various types of textures (note that texture type to be stored is determined by filename only and this is only for preview purposes)"},{"heading":"Zoom In / Zoom Out","level":6,"markdown":"<kbd>NUM +</kbd> / <kbd>NUM -</kbd>\n\nZoom the texture in and out (you can also use mouse wheel to zoom in and out)"},{"heading":"RGB","level":6,"markdown":"Show RGB values on a 0..1 scale (not 0..255)"},{"heading":"Mouse controls","level":5,"markdown":"Hold {{Right Mouse Button and drag the texture by mouse if it cannot fit on screen, use mouse wheel to zoom in and out."},{"heading":"Command Line Conversion","level":4,"markdown":"For command line and batch conversions use Pal2PacE.exe.\n\n**Arguments Usage**:\n\n```\npal2pace [saveoptions] <source> [<destination>]\npal2pac -combine [saveoptions] [options] <source1> <source2> <source3> <source4> <destination>\n```\n\n**SaveOptions**:\n\n```\n        -size=<n>\n\nOptions (obsolete, no longer useful for {{arma1}}):\n        -xborder=<bordersize> (0<bordersize<0.5, default 0.125)\n        -yborder=<bordersize>\n        -mask=<maskname>\n        -water=<watername>\n\nExample of how to generate new [[paa]] files from TGA sources:\n Pal2PacE x:\\Test\\*.tga\n```"},{"heading":"See Also","level":3,"markdown":"- TexView 2\n- PAA File Format\n- Arma: Texture Naming Rules"}],"categories":["ArmA: Armed Assault: Addon Editing","ArmA: Armed Assault: Official Tools","Arma 2: Official Tools","Arma 3: Official Tools"],"groups":["Tools and File Formats"]}